close
Exchange 2016

Installing Exchange Server 2016 Pre-Requisites on Windows Server 2012 R2

maxresdefault

change Server 2016 can be installed on Windows Server 2012 and Windows Server 2012 R2. Exchange 2016 CU3 or later can also be installed on Windows Server 2016. For either version of Windows Server the Standard or Datacenter edition can be used to run Exchange Server 2016. Exchange itself does not rely on any specific features of either the Standard or Datacenter editions.

Note that a full server installation with GUI (referred to as Desktop Experience in Windows Server 2016) is required for Exchange Server 2016, it can’t be installed on a Core mode installation of Windows Server.

There are three possible installations of Exchange Server 2016 that you can perform:

  • Mailbox server role (this is the only mandatory server role)
  • Edge Transport server role (this is optional, and can’t co-exist with the Mailbox server role on the same Windows Server)
  • Management Tools (for admin workstations or servers)

Note that installing the Edge Transport server role on Windows Server 2016 is not supported.

The requirements for each installation type are different, so let’s look at each of them in turn.

Installing Pre-Requisites for an Exchange Server 2016 Mailbox Server

For an Exchange Server 2016 Mailbox server installation open an elevated (run as administrator) PowerShell console and run the following command to install the operating system roles and features.

Windows Server 2012 and 2012 R2

 

exchange-2016-pre-requisites-01

A restart is required after the roles and features have finished installing. If you’d prefer that the server restarts itself automatically simply append -Restart to the command.

After the restart download and install (in order):

The server is now ready to install the Exchange Server 2016 Mailbox server role.

Windows Server 2016

 

Next, install the following (in order):

Installing Pre-Requisites for an Exchange Server 2016 Edge Transport Server

For an Exchange Server 2016 Edge Transport server the pre-requisites installation is a little simpler than for a Mailbox server. Open an elevated PowerShell console and run the following command.

When that has completed download and install (in order):

The server is now ready to install the Exchange Server 2016 Edge Transport role.

Installing Pre-Requisites for the Exchange Server 2016 Management Tools

Exchange Server 2016 uses a web-based administrative interface called the Exchange Admin Center, similar to Exchange Server 2013. There is nothing required to be installed on a workstation or server other than a web browser to access the Exchange Admin Center.

However if you want the Exchange Management Shell to be installed on a management workstation (Windows 8.1 or later) or server (Windows Server 2012 R2 or later) then the requirements are .NET Framework 4.5.2, and then the following Windows features:

 

Next Steps

After installing the pre-requisites you can proceed with installing Exchange Server 2016.

Abdulsalam Garba

The author Abdulsalam Garba

Leave a Response